Results 1 to 7 of 7

Thread: Jzz30 map sensor

  1. #1
    Forum Member 1st year Apprentice
    Join Date
    May 2017
    Location
    Victoria
    Posts
    12

    Default Jzz30 map sensor

    I have bought a 1jz jzz30 non vvti engine that I am looking to transfer into my corona. After getting a auto electrician to have a look I require a map sensor as the one I have on this engine isnít originally from this engine(causing me issues).
    I know this site has many forums for this, some saying you can use any 1jz map sensor or even use 2jz map sensors, but also found many forums saying this is all crap you canít do that.

    Can anyone help me with a correct answer? as most the forums 5 years old now. Iím struggling to find a place I can get the map sensor so hopefully there is another way?

  2. #2
    Junior Member Backyard Mechanic
    Join Date
    Jan 2010
    Location
    Western Australia
    Posts
    241

    Default Re: Jzz30 map sensor

    Part number should be: 89420-24040
    According to ToyoDIY, part number is exclusive to JZZ30, so not the same part no. as JZA70 or the 2JZ. Appears to be out of stock on Amayama.
    As far as I understand, the difference between this one and the others (JZA70, 2JZ, etc) is in the bracket and they actually output the same (0-5v 2 bar sensor) so in theory, the JZA70 and 2JZ MAP sensors (including the boost gauge sender on vvti models) should be pretty interchangeable...

  3. #3
    Forum Member 1st year Apprentice
    Join Date
    May 2017
    Location
    Victoria
    Posts
    12

    Default Re: Jzz30 map sensor

    Cheers Daddio, I'll order me a 2 bar sensor and hopefully everything will be running smoothly

  4. #4
    Forum Member 1st year Apprentice
    Join Date
    May 2017
    Location
    Victoria
    Posts
    12

    Default Re: Jzz30 map sensor

    Unfortunately everything didn't work out, a few map sensors later and still the engine is missing on high revs and it now seems maybe we have an issue with the original ECU which leaves me probably looking for another ECU cause i want the car engineered pass and that is a lot more simple with the original ECU.

  5. #5
    Junior Member Backyard Mechanic
    Join Date
    Jan 2010
    Location
    Western Australia
    Posts
    241

    Default Re: Jzz30 map sensor

    Just a thought....we had a mystery high rpm miss on a 2JZ GTE which turned out to be one coil pack wired opposite. I have no idea why this would cause a miss given its a coil and shouldn't be polarity sensitive, but it did. Easy check that all coil packs are wired same polarity...
    Early 90's JZ ECU's are notorious for leaking caps, that may be worth a look too. Pretty easy to spot, goopy stains and/or corrosion around the base of the capacitor...

  6. #6
    Forum Member 1st year Apprentice
    Join Date
    May 2017
    Location
    Victoria
    Posts
    12

    Default Re: Jzz30 map sensor

    Thanks for the advice Daddio, we checked all the coil packs.
    Even after trying a few map sensors the ecu is telling us that the fault is still the map sensor but after trying so many and checking the wiring we think it might be the ecu.
    Had a look at the ecu but nothing seems to be leaking. Waiting on the electrician to come off holidays and come have a look for us, i can only try so many map sensors.
    One of the coil clips is worn out so i am ordering new ones of those as we speak.

  7. #7
    Junior Member Grease Monkey
    Join Date
    Jun 2010
    Location
    Qld
    Posts
    134

    Default Re: Jzz30 map sensor

    Wiring issue? if it is the ecu it can be really hard to see the leaking caps, you have to get right in there and see if the bottom is bulging or blown out

Similar Threads

  1. Replies: 4
    Last Post: 25-07-2014, 11:11 AM
  2. JZZ30 a340e speed sensor wiring into MX83
    By Cressii in forum Tech and Conversions
    Replies: 4
    Last Post: 17-03-2012, 01:38 AM
  3. jzz30 1jz mapsensor swap to a 2jz m/sensor??
    By gsrt085 in forum Tech and Conversions
    Replies: 10
    Last Post: 29-01-2008, 08:31 PM
  4. Oil Level sensor JZZ30 Soarer
    By rogue-vl in forum Tech and Conversions
    Replies: 11
    Last Post: 26-04-2007, 08:44 AM
  5. jzz30/A340E speed sensor issue
    By lumpy in forum Tech and Conversions
    Replies: 3
    Last Post: 20-01-2006, 01:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •