Page 1 of 2 12 LastLast
Results 1 to 20 of 34

Thread: Oil Pressure light on startup

  1. #1
    Junior Member Carport Converter Z2TT's Avatar
    Join Date
    Nov 2007
    Location
    Western Australia
    Posts
    1,660

    Default Oil Pressure light on startup

    Hi,

    When I start my car, I get the oil pressure light come on for about 1 or 2 seconds after the engine has just started. But it never comes on during driving, only during startup, plus I hear a bit of a grinding noise on startup.

    Just wondering could it be a failing oil pump and could it cause any damage?

    Thanks.

  2. #2
    Junior Member Backyard Mechanic TC1600's Avatar
    Join Date
    Feb 2007
    Location
    SA
    Posts
    329

    Default Re: Oil Pressure light on startup

    Change your oil filter, sounds like the anti-drainback valve has gone (allows oil to drain out of the filter when standing, then takes a few seconds to fill the filter back up).

  3. #3
    Junior Member Grease Monkey
    Join Date
    Jul 2009
    Location
    qld
    Posts
    78

    Default Re: Oil Pressure light on startup

    very common for the oil light to be on for 1-2 seconds its based on pressure and as the car has only just started the pressure isnt there straight away, and just as an fyi most oil filters don't have an anti drain valve in them. check on the ryco site to see if the one they make for the 1g does.
    From experience nothing to worry about. the grinding noise is probably your starter motor
    1985 RT142, 1GGTE,.now with t67-25g
    2009 Ford Fiesta LX
    1970 Ford Cortina MK2 440

  4. #4
    Not trying to be a Carport Converter senn's Avatar
    Join Date
    Jan 2009
    Location
    WA
    Posts
    1,631

    Default Re: Oil Pressure light on startup

    usually if you hear noise on startup and you suspect its oil pressure related, it can be valvetrain noise, until the oil gets up to it. This happens usually after i've done an oil/filter change and the filter is filling up. Also happened when i was running ryco filters instead of toyota.
    "Nice Capri Mate!" yeah get bent......
    Quote Originally Posted by TooF View Post
    fast, cheap and reliable... you can have two.

  5. #5
    Junior Member Carport Converter Z2TT's Avatar
    Join Date
    Nov 2007
    Location
    Western Australia
    Posts
    1,660

    Default Re: Oil Pressure light on startup

    Thanks,

    Yeah the noise seems to be coming from the head. If the filter doesn't have an anti-drainback valve, could this be the cause of the light coming on for 1-3 seconds after startup?

    It has been doing this not just after oil changes but all the time.

  6. #6
    Junior Member Grease Monkey
    Join Date
    Jul 2009
    Location
    qld
    Posts
    78

    Default Re: Oil Pressure light on startup

    what brand oil filter are you using
    1985 RT142, 1GGTE,.now with t67-25g
    2009 Ford Fiesta LX
    1970 Ford Cortina MK2 440

  7. #7
    Junior Member Backyard Mechanic DrNick's Avatar
    Join Date
    May 2008
    Location
    WA
    Posts
    211

    Default Re: Oil Pressure light on startup

    Normal on some vehicles. My 5SFE Celica does it every time. The manual even says only to worry if the light does not turn itself off after 30 seconds (Which is ages!)

  8. #8
    Not trying to be a Carport Converter senn's Avatar
    Join Date
    Jan 2009
    Location
    WA
    Posts
    1,631

    Default Re: Oil Pressure light on startup

    could also be low oil level (i had this issue when my dizzy was pissing oil and i got lazy checking the level)
    "Nice Capri Mate!" yeah get bent......
    Quote Originally Posted by TooF View Post
    fast, cheap and reliable... you can have two.

  9. #9
    Junior Member Carport Converter Z2TT's Avatar
    Join Date
    Nov 2007
    Location
    Western Australia
    Posts
    1,660

    Default Re: Oil Pressure light on startup

    Brand of oil filter is Ryco.
    Oil Level is good, on the full line.

    I used the same oil filter on my other Soarer/1g-gte and I didn't get the check engine oil light.

  10. #10
    Hooligans Holiday Grease Monkey kickstartRA28's Avatar
    Join Date
    Apr 2009
    Location
    QLD
    Posts
    150

    Default Re: Oil Pressure light on startup

    Sounds normal to me it will come on until oil pressure feeds the swtich to turn the dash light off.

  11. #11
    Junior Member Carport Converter Z2TT's Avatar
    Join Date
    Nov 2007
    Location
    Western Australia
    Posts
    1,660

    Default Re: Oil Pressure light on startup

    Ahh ok,

    Just seems weird since my old car didn't do that.

    Could a blocked oil pickup cause this problem?

  12. #12
    advocate for the oldies Carport Converter ian's Avatar
    Join Date
    Nov 2006
    Location
    Eltham vic
    Posts
    1,625

    Default Re: Oil Pressure light on startup

    another thing to consider use a good quality oil
    i had a 528 bmw with a few k on it and the light would stay on for a couple of seconds , and it loved oil , until i put a genuine filter and gtx in it , by the time it needed a ltr of oil it was due for an oilchange any way
    nostalgia is not what it used to be:

  13. #13
    Junior Member Grease Monkey toyoda's Avatar
    Join Date
    Nov 2005
    Location
    Victoria
    Posts
    96

    Default Re: Oil Pressure light on startup

    Hi,

    I would strongly recommend unscrewing the RYKO and looking inside.

    Just because.


    Toyoda

  14. #14
    ANGRY MAN 2011 Chief Engine Builder Admiral coFF33's Avatar
    Join Date
    Nov 2005
    Location
    West Australia
    Posts
    4,444

    Default Re: Oil Pressure light on startup

    My 1JZ/5MGE/1GGTE/2LT and my housemates 3L / 1JZ

    all do it

    because it takes 1 second for the oil pressure to be high enough for the light to go out

    if you have a grinding noise does this only happen on cold start (in morning after its been sitting overnight ?)

    If so, the drainback valve could be the issue, or your running shit oil.

    my 1JZ in the drift soarer does it without fail if ive let it sit overnight and start it the next morning.

  15. #15
    Junior Member Carport Converter Z2TT's Avatar
    Join Date
    Nov 2007
    Location
    Western Australia
    Posts
    1,660

    Default Re: Oil Pressure light on startup

    Yeah usually overnight when i let it sit i get the grinding noise when its fully cold.

    I use Mobil1 Oil 15-40.

    Today when cold it turned on without any the light staying on, but other times the light will stay on for 2 seconds or 3.

  16. #16
    ANGRY MAN 2011 Chief Engine Builder Admiral coFF33's Avatar
    Join Date
    Nov 2005
    Location
    West Australia
    Posts
    4,444

    Default Re: Oil Pressure light on startup

    2 or 3 seconds is a pretty long time,you sure thats not a bit of an exaggeration ?

    1.5 sec or less sounds more like it.

    its normal man. i wouldnt worry bout it.

  17. #17
    Junior Member Carport Converter Z2TT's Avatar
    Join Date
    Nov 2007
    Location
    Western Australia
    Posts
    1,660

    Default Re: Oil Pressure light on startup

    Yep about 2 or 3 seconds most of the time.

    How is it possible for an Anti-drainback valve to fail? debris getting stuck on it and sticking it open?

  18. #18
    Junior Member Backyard Mechanic TC1600's Avatar
    Join Date
    Feb 2007
    Location
    SA
    Posts
    329

    Default Re: Oil Pressure light on startup

    It's just basically a rubber flap (it's the rubber you see through the small holes around the big hole in the middle), I guess with age and hot oil going through it the rubber would harden and not spring back to close off the holes effectively.

  19. #19
    Junior Member Carport Converter Z2TT's Avatar
    Join Date
    Nov 2007
    Location
    Western Australia
    Posts
    1,660

    Default Re: Oil Pressure light on startup

    Thanks TC,

    Today took it for a drive, came back. then started it 30 minutes later to go somewhere else, had the low oil pressure light plus the valve train noise, so it's not only just when cold.

    Might aswell change the filter anyway since it's time for an oil change.

  20. #20
    ANGRY MAN 2011 Chief Engine Builder Admiral coFF33's Avatar
    Join Date
    Nov 2005
    Location
    West Australia
    Posts
    4,444

    Default Re: Oil Pressure light on startup

    use good oil too.

Similar Threads

  1. Aftermarket oil pressure gauge stuck/issue
    By thepeter in forum Tech and Conversions
    Replies: 1
    Last Post: 09-03-2009, 12:24 AM
  2. Fresh 2tg hybrid no oil pressure at idle
    By 2TG KE35 in forum Tech and Conversions
    Replies: 21
    Last Post: 20-08-2007, 02:02 PM
  3. Replies: 8
    Last Post: 18-08-2006, 05:52 PM
  4. AE82 100kw motor Shift Light Install
    By Cuzzo in forum Tech and Conversions
    Replies: 1
    Last Post: 29-12-2005, 10:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •