Results 1 to 4 of 4

Thread: Weber 32/36 swap to 4A-F with problem

  1. #1
    Forum Member 1st year Apprentice
    Join Date
    Dec 2018
    Location
    Alvsborg
    Posts
    41

    Default Weber 32/36 swap to 4A-F with problem

    Hello! I have swaped a 32/36 weber that i had on my 3T-C engine (model name: k740?) it worked perfect on that engine. Notic that the base fitted the 4A-F aswell so swaped it over.

    Started it up and it idles perfectly from start, but as soon as i add som throttle it misfires and dont go up in rpm and dies most of the times.
    Cleaned the carb two times now and put fresh gas, adjusted float and everything i could find. But the problem is still there!

    So i wonder if the jetting could be the problem? cant find any recommendation on what jetting a 4A-f should have, but since the weber kit for the 3T-c also worked on 2T-c i dont se why it wouldn't work on another 1600cc engine.

    Need help since i have no idea how to go forward to fix this or what could be the problem, so any help or pointers would be lovly!

    Thanks!!

    first barrel (main): 135 air: 170
    second barrel: 135 air 160

    Link to the carb: https://www.ebay.com/itm/Weber-Carb-...GcQAvD_BwE:G:s
    Last edited by Ceasar; 10-02-2020 at 06:11 PM.

  2. #2
    Forum Member 1st year Apprentice
    Join Date
    Dec 2018
    Location
    Alvsborg
    Posts
    41

    Default Re: Weber 32/36 swap to 4A-F with problem

    Found the problem "big problem" after along time thinkering about, so though that i would share the solution!

    So it consisted of several combined problems, the main where timing! Since i had a distributer that rotated in the wrong rotation the centrifugal advance (which i didnt know existed on a 4af dizzy) would retard the ignition instead of advance.
    When i sorted the timing out i was alot better but the rest of the problem where a combination of bad adjusted float and bad fuelpump!
    There is still a little bit of hesitation upon full throttle but i think the jetting is a tiny bit of.

    //Case close i guess.

  3. #3
    Forum Member 1st year Apprentice
    Join Date
    Dec 2015
    Location
    Michigan
    Posts
    24

    Default Re: Weber 32/36 swap to 4A-F with problem

    "There is still a little bit of hesitation upon full throttle."

    You need to check the linkage going to the accelerator pump. Bend the wire link going to the arm so there is not any slack in the linkage between the throttle plate and accelerator pump. If it is OK, then move the accelerator pump linkage to the next hole to increase the fuel shot. davew7

  4. #4
    Forum Member 1st year Apprentice
    Join Date
    Dec 2018
    Location
    Alvsborg
    Posts
    41

    Default Re: Weber 32/36 swap to 4A-F with problem

    Thanks for the tips will look into that and se if it solves the problem!

Similar Threads

  1. Blacktop 20v swap into AE92 ignition problem
    By TE35 in forum Tech and Conversions
    Replies: 3
    Last Post: 06-04-2014, 08:09 PM
  2. Replies: 14
    Last Post: 07-05-2013, 03:48 PM
  3. fuel line problem with 32/36 weber
    By ctrain in forum Tech and Conversions
    Replies: 2
    Last Post: 20-04-2012, 04:36 PM
  4. Weber 32/36 onto 4M
    By Ms55 in forum Tech and Conversions
    Replies: 1
    Last Post: 13-05-2010, 05:33 PM
  5. Fire: GZE-swap problem - need ideas
    By ThaChemist in forum Tech and Conversions
    Replies: 6
    Last Post: 08-06-2008, 10:47 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •