Results 1 to 6 of 6

Thread: 4AGZE Troubles.

  1. #1
    Forum Member
    Join Date
    Jul 2018
    Location
    ACT
    Posts
    2

    Default 4AGZE Troubles.

    hey just wondering if anyone could shed some light on an issue im having.
    Recently got the car and it used to boost hard all day everyday.
    now its extremely sluggish but still hits 11psi on the gauge but doesnt seem to want to take off like it used too.
    the intercooler piping does have some oil around the place but not huge amounts and the check engine light is on.
    Im familiar with running diagnostics but havent got that far with the car yet. Thought i would post this here in case there may be common issues to look for with these engines.

    Thanks for reading

  2. #2
    Junior Member Grease Monkey
    Join Date
    Jul 2007
    Location
    VICTORIA
    Posts
    120

    Default Re: 4AGZE Troubles.

    Where is your gauge mounted? are you seeing 11psi at the manifold? check your ignition timing too?

  3. #3
    ToyotaCarClub.net Domestic Engineer Starfire's Avatar
    Join Date
    Sep 2005
    Location
    South Australia
    Posts
    694

    Default Re: 4AGZE Troubles.

    If your check engine light is on, then you have some sort of sensor fault. Don't be lazy; run the diag and then you will know exactly what the issue is.

    If it's still boosting but not making power, that probably indicates that the ignition timing is way off, which is common in a limp home situation, especially with a failed knock sensor.

    Cheers,
    Terry
    1987 AW11 MR2 Supercharger (4AGZE)
    1974 TA22 Celica (2TG bored and stroked)

    Thanks to James Cameron's Terminator films, we know that robots are stronger, faster, tougher and more Austrian than the rest of us.

  4. #4
    Forum Member
    Join Date
    Jul 2018
    Location
    ACT
    Posts
    2

    Default Re: 4AGZE Troubles.

    Thanks for the replys ☺😊
    Ill have a look for a diagnostic guide now. Any suggestions on a nice simple to read one?

  5. #5
    ToyotaCarClub.net Domestic Engineer Starfire's Avatar
    Join Date
    Sep 2005
    Location
    South Australia
    Posts
    694

    Default Re: 4AGZE Troubles.

    It depends on the car, but the BGB will have a section for fault codes.
    1987 AW11 MR2 Supercharger (4AGZE)
    1974 TA22 Celica (2TG bored and stroked)

    Thanks to James Cameron's Terminator films, we know that robots are stronger, faster, tougher and more Austrian than the rest of us.

  6. #6
    1MZ > 2JZ Carport Converter knightrous's Avatar
    Join Date
    Jul 2009
    Location
    NSW
    Posts
    1,771

    Default Re: 4AGZE Troubles.

    This are the ones associated with the AW11 4AGZE, but should be similar.

    http://mr2wiki.com/MKI/EngineErrorCodes
    TrackDub - 89' AW11 1MZFE | SlushDub - 89' AW11 4AGZE | SW21MZ - 90' SW20 1MZFE
    http://www.midrear.net - My AW11 blog of DIY mechanics, grassroots motorsports and driveway shenanigans...

Similar Threads

  1. having some battery troubles..
    By HAVABEER in forum Tech and Conversions
    Replies: 6
    Last Post: 10-06-2009, 08:39 PM
  2. 3T/2TG Hybrid AFR Troubles
    By Celica_73 in forum Tech and Conversions
    Replies: 24
    Last Post: 22-04-2009, 09:46 AM
  3. Tacho troubles
    By chrizer in forum Tech and Conversions
    Replies: 6
    Last Post: 13-06-2007, 10:39 AM
  4. 4M Troubles! :(
    By Brad-KE35 in forum Tech and Conversions
    Replies: 39
    Last Post: 02-06-2006, 08:56 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •