Page 3 of 3 FirstFirst 123
Results 31 to 32 of 32

Thread: ANOTHA ONE - non-vvti 1JZ-gte out of a JZA70 breaks up under WOT ""HELP MEEE""

  1. #31
    Junior Member Backyard Mechanic
    Join Date
    Jan 2010
    Location
    Western Australia
    Posts
    236

    Default Re: ANOTHA ONE - non-vvti 1JZ-gte out of a JZA70 breaks up under WOT ""HELP MEEE""

    Quote Originally Posted by samkaos View Post
    BTW, V6 Camry igniters do work on J engines, even tho the part numbers are different. Just plug them in and they work (I have done it) - Well don't forget to ground the body of the igniter lol
    JZ ignitors are earthed through the loom (unlike predecessor 7M that was earthed through the bracket, quite badly so worth the quick mod to add an earth lead)...I've actually had a 2JZGTE (JZS147 in JZA70 chassis) running fine with the ignitor not even bolted down...so good tip if the V6 ignitor is 'old skool' enough to require a chassis earth

  2. #32
    Forum Member 1st year Apprentice
    Join Date
    Mar 2017
    Location
    WI
    Posts
    17

    Default Re: ANOTHA ONE - non-vvti 1JZ-gte out of a JZA70 breaks up under WOT ""HELP MEEE""

    Ahh yes, good thing to note. I don't have it grounded as its mounted with durolock on top of my ECU. I will add a ground!

Similar Threads

  1. Running a VVTi motor with VVTi "off"
    By JustenGT8 in forum Tech and Conversions
    Replies: 4
    Last Post: 01-04-2014, 08:24 PM
  2. Replies: 8
    Last Post: 02-11-2013, 05:49 AM
  3. ST162 - "GTR" vs "SX" any differences?
    By XiL3D in forum Tech and Conversions
    Replies: 11
    Last Post: 06-07-2007, 11:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •