Page 1 of 2 12 LastLast
Results 1 to 20 of 22

Thread: Aircon and engine cutting out(with engine light) when moving from stop

  1. #1
    Forum Member 1st year Apprentice
    Join Date
    Nov 2006
    Location
    NSW
    Posts
    44

    Default Aircon and engine cutting out(with engine light) when moving from stop

    When i have the aircon running and i'm at the lights, when i accelerate most times the car seems like its going to stall, and it cuts out, and then the engine kicks back in. it revs up, cuts out, then revs up again.

    while it does this the engine light flicks on then off. Its like theres a vacuum leak or something.

    car is 1990 SV21 wagon. Could this just be that its an old car ?

  2. #2
    Junior Member Grease Monkey MacroP's Avatar
    Join Date
    Oct 2005
    Location
    WA
    Posts
    121

    Default Re: Aircon and engine cutting out(with engine light) when moving from stop

    Quote Originally Posted by Thraxeh
    Could this just be that its an old car ?
    No. It means there's something wrong with the engine and/or engine management. You need to check the 'engine fault codes'. Plenty of info here to find out how to do this.
    Last edited by MacroP; 24-11-2006 at 01:04 PM.
    MX83 1UZ Conversion. UZZ31 engine, UCF10 Sump, UZS131 Tranny and engine fan idler. Custom exhaust and 147rwKWs.

  3. #3
    back into it Chief Engine Builder
    Join Date
    Mar 2006
    Location
    nsw
    Posts
    3,991

    Default Re: Aircon and engine cutting out(with engine light) when moving from stop

    you have no idleup by the sound of it

  4. #4
    BBP racing 3rzfe+T Carport Converter BeRad's Avatar
    Join Date
    Oct 2005
    Location
    QLD
    Posts
    1,367

    Default Re: Aircon and engine cutting out(with engine light) when moving from stop

    agreed with mick.
    Only the shittiest of wines come in 5 litres

    boosted 3rz hilux *new project* mwahaha
    http://www.toymods.net/forums/showth...940#post134940

  5. #5
    Forum Member 1st year Apprentice
    Join Date
    Nov 2006
    Location
    NSW
    Posts
    44

    Default Re: Aircon and engine cutting out(with engine light) when moving from stop

    Quote Originally Posted by kingmick
    you have no idleup by the sound of it
    idleup ? whats that? this is the code i get

    Code 43 is "Starter Signal"
    No STA signal to ECU when vehicle stopped and engine running at over 800RPM.
    Problem area : Ignition Switch Circuit, Ignition Switch, ECU.

    what should i be looking at ?

  6. #6
    Fuel Economy Warrior Carport Converter Vios-GT_07's Avatar
    Join Date
    Mar 2006
    Location
    WA
    Posts
    1,751

    Default Re: Aircon and engine cutting out(with engine light) when moving from stop

    ah ha.. so it is an electrical thing..

    coils, ignitors, relays, ECU might have shat itself.. RPM signals maybe? even Crank angle sensor, tps, etc etc.... hm... question is, where should you start?

    (at frist i was thinking it might be an ignition relay fault)
    Research has shown child in front seat causes accidents, accident in back seat causes child

  7. #7
    Forum Member Grease Monkey
    Join Date
    Dec 2005
    Location
    NSW
    Posts
    58

    Default Re: Aircon and engine cutting out(with engine light) when moving from stop

    does it run rough at lights before you take off??

    and is it only when the a/con system is running??

    have you checked your a/con solenoid?? When the air con system is running, your engine should bump up the rpms via a solenoid switch. Take it to an auto elec, or even a normal mechanic. They should know where its located.

    Thanks
    Blake

  8. #8
    Junior Member Grease Monkey
    Join Date
    Aug 2006
    Location
    Queensland
    Posts
    176

    Smile Re: Aircon and engine cutting out(with engine light) when moving from stop

    If your camry has the 1S-Ci engine, the load signal fault code is 11

    If you have the 3S-FE engine, the code is 51.

    It would pay to check your wiring connections and check the A/C Amplifier (Located under the glovebox) I can send you the info on this and a list of the fault codes if you don't have a w/s manual.

    I had exactly the same problem with our SV21. Everything electrical checked out ok.

    The problem is now cured, here's how :

    Try the fault test, if all is ok, try removing your idle speed control valve, take it apart carefully and give it a thorough clean. Also, as you will need to remove the throttle body, clean it too.

    Made the world of difference to ours. The ISC valve on ours was gummed up to the point where the shaft had barely any movement.

    Clean it with carby cleaner BUT keep the stuff away from the electrical end of the valve as I've heard it can cause damage.

    Let me know if you need any more info

    Cheers,
    Andrew

  9. #9
    Forum Member 1st year Apprentice
    Join Date
    Nov 2006
    Location
    NSW
    Posts
    44

    Default Re: Aircon and engine cutting out(with engine light) when moving from stop

    its the 3S-FE engine. As i said it returned this code

    Code 43 is "Starter Signal"
    No STA signal to ECU when vehicle stopped and engine running at over 800RPM.
    Problem area : Ignition Switch Circuit, Ignition Switch, ECU.

    I've never removed any of the things you mentioned (ISC valve, and the throttle body)

    are these easy to remove and replace ?

  10. #10
    Junior Member Grease Monkey
    Join Date
    Aug 2006
    Location
    Queensland
    Posts
    176

    Smile Re: Aircon and engine cutting out(with engine light) when moving from stop

    There is a thread buried in this website somwhere. It has some pictures too.

    Anyway, yes, it's an easy job to do.

    Make sure you have the following : throttle body gasket ( paper so you can easily make one as I did), spare vacuum hose, spare coolant hose & clamps. If you're careful you can reuse the rubber gasket between the ISC valve and the throttle body.

    Disconnect neg battery terminal (just in case)
    Remove air intake duct and crankcase vent hose
    Disconnect throttle cable and kickdown cable (if it's an auto)
    Disconnect 2 coolant hoses and the vacuum hose from the ISC valve (underneath it)
    (remember to top up radiator when finished as you will lose a little coolant)
    Disconnect the wiring from the ISC valve ( don't worry it only goes on one way)
    Undo the 4 bolts securing the throttle body to the manifold and remove the throttle body & ISC valve as an assembly.
    Pretty straight forward from here, separate the ISC valve from the throttle body.
    Go to town with the carby cleaner ( if it's anything like mine it'll be clogged up with crap)
    Re - assembly is just the reverse of the above.

    If need be, I have a picture in my w/s manual. I can scan and email it to you if it would help.

    Hope all goes well.
    Andrew.

  11. #11
    Forum Member 1st year Apprentice
    Join Date
    Nov 2006
    Location
    NSW
    Posts
    44

    Default Re: Aircon and engine cutting out(with engine light) when moving from stop

    Quote Originally Posted by ajh
    There is a thread buried in this website somwhere. It has some pictures too.

    Anyway, yes, it's an easy job to do.

    Make sure you have the following : throttle body gasket ( paper so you can easily make one as I did), spare vacuum hose, spare coolant hose & clamps. If you're careful you can reuse the rubber gasket between the ISC valve and the throttle body.

    Disconnect neg battery terminal (just in case)
    Remove air intake duct and crankcase vent hose
    Disconnect throttle cable and kickdown cable (if it's an auto)
    Disconnect 2 coolant hoses and the vacuum hose from the ISC valve (underneath it)
    (remember to top up radiator when finished as you will lose a little coolant)
    Disconnect the wiring from the ISC valve ( don't worry it only goes on one way)
    Undo the 4 bolts securing the throttle body to the manifold and remove the throttle body & ISC valve as an assembly.
    Pretty straight forward from here, separate the ISC valve from the throttle body.
    Go to town with the carby cleaner ( if it's anything like mine it'll be clogged up with crap)
    Re - assembly is just the reverse of the above.

    If need be, I have a picture in my w/s manual. I can scan and email it to you if it would help.

    Hope all goes well.
    Andrew.
    thanks for the write up, i have a W.S that i found on the internet, and i will have a look through it tomorrow. Sourcing those gaskets and hoses wouldnt be to hard ? places like Auto-one should have them correct ?

  12. #12
    My Missus is a Domestic Engineer BradW's Avatar
    Join Date
    Oct 2005
    Location
    NSW
    Posts
    661

    Default Re: Aircon and engine cutting out(with engine light) when moving from stop

    Quote Originally Posted by Thraxeh
    idleup ? whats that? this is the code i get

    Code 43 is "Starter Signal"
    No STA signal to ECU when vehicle stopped and engine running at over 800RPM.
    Problem area : Ignition Switch Circuit, Ignition Switch, ECU.

    what should i be looking at ?
    Quote Originally Posted by Vios-GT_07
    ah ha.. so it is an electrical thing..

    coils, ignitors, relays, ECU might have shat itself.. RPM signals maybe? even Crank angle sensor, tps, etc etc.... hm... question is, where should you start?

    (at frist i was thinking it might be an ignition relay fault)
    The reason it is giving the code 43, starter signal, is because the ecu is seeing the engine revs drop (when the engine stutters and goes to stall) without seeing a start signal at the same time. This code is a result of the problem, not the cause.

    Do as ajh has said and your problems will be solved.

    Quote Originally Posted by Thraxeh
    Sourcing those gaskets and hoses wouldnt be to hard ? places like Auto-one should have them correct ?
    Yeah, you should be able to get them from any spare parts place. If they don't have them they should be able to get them in for you. Worst case you can always go genuine.
    Brad

    Old Corollas never die...

    My KE30
    Updated 15/7/2007............ yes, I need to pull my finger out.

  13. #13
    Junior Member Grease Monkey
    Join Date
    Aug 2006
    Location
    Queensland
    Posts
    176

    Smile Re: Aircon and engine cutting out(with engine light) when moving from stop

    You would need to go genuine for the rubber gasket between the ISC valve and the throttle body, HOWEVER if you separate the ISC valve from the throttle body carefully, you will be able to re - use the old one as I did with mine.
    It's made from the same black rubber they use in o rings.

    With the paper gasket, if you can't get one, just get a roll of gasket paper ( auto one would sell it) and trace around the throttle body and cut your own one. I did this as I already had the paper and I'm also known to be a tight arse!!

    It's simply a square - ish gasket with about a 2 1/2 inch hole in the middle and four bolt holes, one in each corner.

    As for the hoses, I mentioned having spares, only because I found myself doing a trip to the auto shop half way through the job. Lucky the wife hadn't taken my car!!!!
    As you would know, once you disconnect old hoses, the usual thing is for them to split or break when being refitted.

    On our car, the coolant hoses are roughly the same diameter as the vacuum hose ( about 8mm inside diameter I think ( just check to be sure). and as usual the clamps were so corroded I had to cut one of them off.

    By the way, it would pay to plug the coolant hoses when you remove them, I only lost about a cup full of coolant by doing this.

    Happy fixing!!!

  14. #14
    Forum Member 1st year Apprentice
    Join Date
    Nov 2006
    Location
    NSW
    Posts
    44

    Default Re: Aircon and engine cutting out(with engine light) when moving from stop

    Also, i forgot to mention, the car idles just over 1000rpm with no AC. i hope this confirms the ISC valve needing a clean..

    I started the car with while shorting the diagnostics, and it came up with 43 again, but the revs dropped to 700rpm, then i stopped the car, started again with out doing the codes, and it went back to 1000rpm...

    whats going on ? i think that means the ISC is fine
    Last edited by Thraxeh; 02-12-2006 at 01:42 PM.

  15. #15
    Junior Member Grease Monkey
    Join Date
    Aug 2006
    Location
    Queensland
    Posts
    176

    Smile Re: Aircon and engine cutting out(with engine light) when moving from stop

    The easiest way to check the operation of the ISC valve is to start the car, then turn on the A/C. When the compressor cuts in, you should hear the engine idle speed dip slightly for about 1/2 a second, then go back up to normal idle speed.

    When the compressor cuts out, the idle speed will go up slightly and drop back down to normal speed.

    Put simply, its purpose is to maintain the idle spped at a constant level when various loads are put on the engine. EG: A/C, Power Steering, etc.

  16. #16
    Forum Member 1st year Apprentice
    Join Date
    Nov 2006
    Location
    NSW
    Posts
    44

    Default Re: Aircon and engine cutting out(with engine light) when moving from stop

    Quote Originally Posted by ajh
    The easiest way to check the operation of the ISC valve is to start the car, then turn on the A/C. When the compressor cuts in, you should hear the engine idle speed dip slightly for about 1/2 a second, then go back up to normal idle speed.

    When the compressor cuts out, the idle speed will go up slightly and drop back down to normal speed.

    Put simply, its purpose is to maintain the idle spped at a constant level when various loads are put on the engine. EG: A/C, Power Steering, etc.
    when i turn on the AC, it does that.

    although its constantly at 1000rpm. UNLESS i short the terminals that give me a code, then it goes up a little for 5 secs, and then drops down to 700rpm. I've taken this out of the WS manual for testing the ISC valve.

    When you had your ISC/TB problem, did yours idle at just over 1000 ?
    Last edited by Thraxeh; 02-12-2006 at 03:48 PM.

  17. #17
    Junior Member Grease Monkey
    Join Date
    Aug 2006
    Location
    Queensland
    Posts
    176

    Smile Re: Aircon and engine cutting out(with engine light) when moving from stop

    Mine only idled fast for a couple of secs when I shorted out the diagnostic terminals ( as per the w/s manual)

    It then dropped down to normal. 650-700 rpm.

    Under normal driving conditions, mine would idle ok, a little fast, which I found the ignition timing was advanced way too far, so that was easy fixed. however when the A/C was switched on, the engine would nearly stall, then crank itself up again. This would repeat over and over until the A/C was switched off. The tacho needle would bounce up and down like a yo yo while this was happening, and the A/C compressor would cut in and out constantly.

    I'm assuming you've checked the output of the A/C amplifier to eliminate that as a possible source of the problem. ( the w/s manual has a procedure for checking this too) It plays a role in sending a signal through to the ISC valve.

    To test it, you need to have the engine running with the A/C on. On mine, I had to manually wind the idle speed up so the car would idle with the A/C on to perform the test. The idle speed screw is on the top of the throttle body. Wind it anti clockwise to increase the speed and vice versa to decrease.

  18. #18
    Junior Member Grease Monkey
    Join Date
    Aug 2006
    Location
    Queensland
    Posts
    176

    Smile Re: Aircon and engine cutting out(with engine light) when moving from stop

    Sorry, One other thing I forgot to mention,

    On the opposite end of the manifold to where the throttle body sits, you will see a device ( not sure of the correct name for it, some sort of adjustable modulator perhaps???) with vacuum tubes connected to it and a spring loaded knob in the bottom of it., they are tied in with the ISC valve and to another electrically operated vacuum switch mounted on the firewall.

    On the electric vacuum switch, do a quick check with your multimeter to make sure the switch is operating. From memory, I think it has voltage applied to it when the A/C is off and no voltage when the A/C is on. ( again, the manual will show you in more detail)

    Also, just check all those vacuum lines to eliminate the possibility of a split or broken line making the idle speed go crazy. In particular, the big vac hose that runs from the ISC valve to the other end of the manifold. Mine literally crumbled when I disturbed it!!

    I'm seriously thinking of buying a load of shares in one of the companies that manufactures vacuum hose. With all these people working on old toyotas, (camrys in particular) there's a fortune to be made!!!!!!!!!

  19. #19
    Forum Member 1st year Apprentice
    Join Date
    Nov 2006
    Location
    NSW
    Posts
    44

    Default Re: Aircon and engine cutting out(with engine light) when moving from stop

    Quote Originally Posted by ajh
    Sorry, One other thing I forgot to mention,

    On the opposite end of the manifold to where the throttle body sits, you will see a device ( not sure of the correct name for it, some sort of adjustable modulator perhaps???) with vacuum tubes connected to it and a spring loaded knob in the bottom of it., they are tied in with the ISC valve and to another electrically operated vacuum switch mounted on the firewall.

    On the electric vacuum switch, do a quick check with your multimeter to make sure the switch is operating. From memory, I think it has voltage applied to it when the A/C is off and no voltage when the A/C is on. ( again, the manual will show you in more detail)

    Also, just check all those vacuum lines to eliminate the possibility of a split or broken line making the idle speed go crazy. In particular, the big vac hose that runs from the ISC valve to the other end of the manifold. Mine literally crumbled when I disturbed it!!

    I'm seriously thinking of buying a load of shares in one of the companies that manufactures vacuum hose. With all these people working on old toyotas, (camrys in particular) there's a fortune to be made!!!!!!!!!
    yes, i found this, although i dont think its linked to the ISC, as it bypasses the throttle body(its on the other side of the plenum), and lets in air that way.

    I found that the AC Idle up is working perfectly, i also screwed the idle screw on the throttle body to decrease the idle, but its still at 1000rpm, but the engine noise did change to sound like it was at a lower RPM.

    vacuum lines seem fine as well.

    i have to do some tests on the ECU, and see that its recieving the signal's it needs

  20. #20
    Junior Member Grease Monkey
    Join Date
    Aug 2006
    Location
    Queensland
    Posts
    176

    Smile Re: Aircon and engine cutting out(with engine light) when moving from stop

    FYI: It's a bit hard to see, but if you put your hand down under that vacuum thing I was referring to, you will feel a large vacuum hose connected to the bottom it. This hose runs down to a steel tube which runs across under the manifold, and has another rubber tube on the other end going up to the ISC valve.

    Do you have a tachometer / multimeter that you can connect up to check the idle speed?
    I found the tacho on the car is not the most accurate.

    I bought one from Supercheap Auto ( if they exist in NSW) for $39. It's a handy thing to have as it is also a multimeter and measures dwell too.

    By the way, did you check the A/C amplifier to make sure it's working?

    With the fast idle, it may even pay to check your ignition timing. As I said with ours, it was advanced too far, not enough to ping ( the rattling noise under heavy load) but it was causing the idle speed to increase somewhat.

    Anyway, keep us informed on what you find.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •